WordPress increases PHP recommendation to 7.2

Reported this week, news that the minimum recommended version of PHP for WordPress has been updated to 7.2. If you want to install a new version of WordPress you’ll need to ensure your hosting setup is 7.2 or higher capable. You’ll find that our WordPress platform is well ahead of the curve. We’re currently deploying 7.3 as standard, and looking at 7.4, too.

It’s been more than a year since PHP 5.6 and 7.0 reached the end of their supported lifespan, with updates and security fixes ceasing way back in December 2018. As noted by WP Tavern and WordPress.org’s own data, more than 40% of sites are potentially still using these old and insecure versions of PHP.

If you are using an older version of PHP (this mainly affects our Professional Hosting accounts) we’d recommended updating ASAP. We wrote about the huge issues facing this insecure code back in December 2018, and these remain – indeed if anything they’ve grown.

As ever, just drop us a line to support@34sp.com if you have any queries about your site and PHP version. Many users report that they’re unable to move past 5.6 as they use a plugin or theme that hasn’t been updated – we can usually recommend a modern alternative that will enable you to upgrade!

Comments

    Sign up to our newsletter

    Get the latest tutorials, videos and special offers from 34SP.com.

    Thanks for signing up!